Logo Bharat Datacenter Status page

Scheduled Emergency Maintenance Activity for Network Migration

  • Monitoring
    Re-Scheduled this Network Optimization activity on 14 December 2025, 2-3AM IST. We expect no downtime on any of the services.
  • Monitoring
    There is a scheduled maintainence by one of our upstreams. Downtime of ~10min is expected for certain users who have specifically opted for upstream(Ishan Technologies). For other users, there is no downtime expected