Logo Bharat Datacenter Status page

Tata Communications Downtime

  • Resolved
    The issue has been addressed with the TCL team and full network connectivity is back.
  • Investigating
    There is an ongoing outage at Tata DIA causing outage across several services. We have advertised our prefixes on Vodafone backup network and services are back online.